Troubleshooting

Order Not Found When Paying through DocData PSP

Problem:

When you pay an order through DocData PSP you see the message that the order is processed successfully but it cannot be seen from the order history details page. The message that the order is not found is shown. The order is saved to the database with the 'New' payment status, which does not update.

Applies to:
Sana Commerce v8.1 when paying through DocData PSP

Cause:

The length of the unique merchant transaction reference in DocData (merchant_transaction_id) is limited with 35 characters.
Sana Commerce forms the transaction ID, which is sent to DocData, in the following format: [order type]-[order id]-[website id].

e.g. Order-ORD-12012000006-SanaStore

If the transaction ID is more than 35 characters, the ID is cut to 35 characters by DocData PSP and the order status does not update in the webshop.

Solution:

To avoid this problem the length of the website and order IDs, used in formation of the transaction ID, should be limited. Make sure that the combination of the order type (order or quote), order ID and website ID, which forms the transaction ID and is sent to DocData, should not exceed 35 characters.

You can limit the amount of characters used in the Website ID. If you want to change the website ID it should be changed in:

  • SQL database:
Provider/ Connector SQL database tables 
Sana Commerce Provider
  • Customers
  • MobileNavigations
  • Navigations
  • NewsletterSubscriptions
  • Orders
  • PaymentMethods
  • ProductCategories
  • ProductEnrichments
  • ProductReviews
  • Products
  • ProductSearchIndexes
  • ProductSets
  • ProductVariants
  • PromotionCoupons
  • RelatedProducts
  • Settings
  • ShippingMethods
  • ShopAccounts
  • StockRanges
  • Translations
  • VariantComponents
  • WebsiteDomains
  • WebsiteLanguages
  • WebsiteRedirects
  • Websites
NAV / AX Connector
  • EntityProperties
  • MobileNavigations
  • Navigations
  • NewsletterSubscriptions
  • PaymentMethods
  • ProductEnrichments
  • ProductReviews
  • ProductSearchIndexes
  • ProductSets
  • PromotionCoupons
  • Settings
  • StockRanges
  • Translations
  • WebsiteDomains
  • WebsiteLanguages
  • WebsiteRedirects
  • Websites
  • In the <sites> section of the Frontend 'web.config' file.
  • In the <sites> and <tasks> sections of the Backoffice 'web.config' file.
  • In case of NAV / AX Connector the website ID should be also changed in the 'Webshop' card in NAV / AX.

You can limit the amount of characters used in generation of the order IDs by configuring the No. Series rules.

For Sana Commerce Provider it can be done in the SQL database, the 'Numbering' table.

For Sana Commerce - NAV Connector it can be done in NAV: Departments -> Administration -> General -> No. Series.

For Sana Commerce - AX Connector it can be done in AX: Basic -> Setup -> Number sequences -> Number sequences.